]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/janus-gateway/janus-gateway.mk
janus-gateway: make video call plugin optional
[coffee/buildroot.git] / package / janus-gateway / janus-gateway.mk
1 ################################################################################
2 #
3 # janus-gateway
4 #
5 ################################################################################
6
7 JANUS_GATEWAY_VERSION = v0.2.1
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPLv3
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
11
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14         libsrtp host-gengetopt libglib2 openssl 
15
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
19
20 define JANUS_GATEWAY_M4
21         mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
24
25 JANUS_GATEWAY_CONF_OPTS = \
26         --disable-data-channels \
27         --disable-rabbitmq
28
29 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE),y)
30 JANUS_GATEWAY_DEPENDENCIES += opus
31 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
32 else
33 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
34 endif
35
36 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST),y)
37 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
38 else
39 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-echotest
40 endif
41
42 ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY),y)
43 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-recordplay
44 else
45 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-recordplay
46 endif
47
48 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
49 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
50 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
51 else
52 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
53 endif
54
55 ifeq ($(BR2_PACKAGE_JANUS_STREAMING),y)
56 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-streaming
57 else
58 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-streaming
59 endif
60
61 ifeq ($(BR2_PACKAGE_JANUS_TEXT_ROOM),y)
62 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-textroom
63 else
64 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-textroom
65 endif
66
67 ifeq ($(BR2_PACKAGE_JANUS_VIDEO_CALL),y)
68 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-videocall
69 else
70 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-videocall
71 endif
72
73 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
74 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
75 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
76 else
77 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
78 endif
79
80 ifeq ($(BR2_PACKAGE_LIBOGG),y)
81 JANUS_GATEWAY_DEPENDENCIES += libogg
82 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
83 else
84 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
85 endif
86
87 # Parallel build broken
88 JANUS_GATEWAY_MAKE = $(MAKE1)
89
90 $(eval $(autotools-package))