]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/linux-tools/linux-tool-cpupower.mk.in
log4cplus: add C++11 dependencies
[coffee/buildroot.git] / package / linux-tools / linux-tool-cpupower.mk.in
1 ################################################################################
2 #
3 # cpupower
4 #
5 ################################################################################
6
7 LINUX_TOOLS += cpupower
8
9 CPUPOWER_DEPENDENCIES = pciutils $(TARGET_NLS_DEPENDENCIES)
10
11 CPUPOWER_MAKE_OPTS = CROSS=$(TARGET_CROSS) \
12         CPUFREQ_BENCH=false \
13         NLS=false \
14         LDFLAGS=$(TARGET_NLS_LIBS) \
15         DEBUG=false
16
17 define CPUPOWER_BUILD_CMDS
18         $(Q)if test ! -f $(LINUX_DIR)/tools/power/cpupower/Makefile ; then \
19                 echo "Your kernel version is too old and does not have the cpupower tool." ; \
20                 echo "At least kernel 3.4 must be used." ; \
21                 exit 1 ; \
22         fi
23
24         $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
25                 $(CPUPOWER_MAKE_OPTS) \
26                 cpupower
27 endef
28
29 define CPUPOWER_INSTALL_STAGING_CMDS
30         $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
31                 $(CPUPOWER_MAKE_OPTS) \
32                 DESTDIR=$(STAGING_DIR) \
33                 cpupower_install
34 endef
35
36 define CPUPOWER_INSTALL_TARGET_CMDS
37         $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
38                 $(CPUPOWER_MAKE_OPTS) \
39                 DESTDIR=$(TARGET_DIR) \
40                 cpupower_install
41 endef