]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/protobuf/protobuf.mk
Normalize separator size to 80
[coffee/buildroot.git] / package / protobuf / protobuf.mk
1 ################################################################################
2 #
3 # protobuf
4 #
5 ################################################################################
6
7 PROTOBUF_VERSION = 2.4.1
8 PROTOBUF_SOURCE = protobuf-$(PROTOBUF_VERSION).tar.gz
9 PROTOBUF_SITE = http://protobuf.googlecode.com/files/
10 PROTOBUF_LICENSE = BSD-3c
11 PROTOBUF_LICENSE_FILES = COPYING.txt
12
13 # N.B. Need to use host protoc during cross compilation.
14 PROTOBUF_DEPENDENCIES = host-protobuf
15 PROTOBUF_CONF_OPT = --with-protoc=$(HOST_DIR)/usr/bin/protoc
16
17 PROTOBUF_INSTALL_STAGING = YES
18
19 ifeq ($(BR2_PACKAGE_ZLIB),y)
20 PROTOBUF_DEPENDENCIES += zlib
21 endif
22
23 $(eval $(autotools-package))
24 $(eval $(host-autotools-package))