]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/janus-gateway/janus-gateway.mk
janus-gateway: make sofia-sip a optional dependency
[coffee/buildroot.git] / package / janus-gateway / janus-gateway.mk
1 ################################################################################
2 #
3 # janus-gateway
4 #
5 ################################################################################
6
7 JANUS_GATEWAY_VERSION = v0.2.1
8 JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,$(JANUS_GATEWAY_VERSION))
9 JANUS_GATEWAY_LICENSE = GPLv3
10 JANUS_GATEWAY_LICENSE_FILES = COPYING
11
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
14         libsrtp host-gengetopt libglib2 openssl 
15
16 # Straight out of the repository, no ./configure, and we also patch
17 # configure.ac.
18 JANUS_GATEWAY_AUTORECONF = YES
19
20 define JANUS_GATEWAY_M4
21         mkdir -p $(@D)/m4
22 endef
23 JANUS_GATEWAY_POST_PATCH_HOOKS += JANUS_GATEWAY_M4
24
25 JANUS_GATEWAY_CONF_OPTS = \
26         --disable-data-channels \
27         --disable-rabbitmq
28
29 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY),y)
30 JANUS_GATEWAY_DEPENDENCIES += sofia-sip
31 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-sip
32 else
33 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-sip
34 endif
35
36 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS),y)
37 JANUS_GATEWAY_DEPENDENCIES += libwebsockets
38 JANUS_GATEWAY_CONF_OPTS += --enable-websockets
39 else
40 JANUS_GATEWAY_CONF_OPTS += --disable-websockets
41 endif
42
43 ifeq ($(BR2_PACKAGE_OPUS),y)
44 JANUS_GATEWAY_DEPENDENCIES += opus
45 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-audiobridge
46 else
47 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
48 endif
49
50 ifeq ($(BR2_PACKAGE_LIBOGG),y)
51 JANUS_GATEWAY_DEPENDENCIES += libogg
52 JANUS_GATEWAY_CONF_OPTS += --enable-plugin-voicemail
53 else
54 JANUS_GATEWAY_CONF_OPTS += --disable-plugin-voicemail
55 endif
56
57 # Parallel build broken
58 JANUS_GATEWAY_MAKE = $(MAKE1)
59
60 $(eval $(autotools-package))