]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/mutt/mutt.mk
mutt: bump to version 1.9.5
[coffee/buildroot.git] / package / mutt / mutt.mk
1 ################################################################################
2 #
3 # mutt
4 #
5 ################################################################################
6
7 MUTT_VERSION = 1.9.5
8 MUTT_SITE = https://bitbucket.org/mutt/mutt/downloads
9 MUTT_LICENSE = GPL-2.0+
10 MUTT_LICENSE_FILES = GPL
11 MUTT_DEPENDENCIES = ncurses
12 MUTT_CONF_OPTS = --disable-doc --disable-smtp
13
14 ifeq ($(BR2_PACKAGE_LIBICONV),y)
15 MUTT_DEPENDENCIES += libiconv
16 MUTT_CONF_OPTS += --enable-iconv
17 endif
18
19 ifeq ($(BR2_PACKAGE_LIBIDN),y)
20 MUTT_DEPENDENCIES += libidn
21 MUTT_CONF_OPTS += --with-idn
22 else
23 MUTT_CONF_OPTS += --without-idn
24 endif
25
26 ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)
27 MUTT_CONF_OPTS += --enable-imap
28 else
29 MUTT_CONF_OPTS += --disable-imap
30 endif
31
32 ifeq ($(BR2_PACKAGE_MUTT_POP3),y)
33 MUTT_CONF_OPTS += --enable-pop
34 else
35 MUTT_CONF_OPTS += --disable-pop
36 endif
37
38 # SSL support is only used by imap or pop3 module
39 ifneq ($(BR2_PACKAGET_MUTT_IMAP)$(BR2_PACKAGE_MUTT_POP3),)
40 ifeq ($(BR2_PACKAGE_OPENSSL),y)
41 MUTT_DEPENDENCIES += openssl
42 MUTT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
43 else
44 MUTT_CONF_OPTS += --without-ssl
45 endif
46 else
47 MUTT_CONF_OPTS += --without-ssl
48 endif
49
50 # Avoid running tests to check for:
51 #  - target system is *BSD
52 #  - C99 conformance (snprintf, vsnprintf)
53 #  - behaviour of the regex library
54 #  - if mail spool directory is world/group writable
55 #  - we have a working libiconv
56 MUTT_CONF_ENV += \
57         mutt_cv_bsdish=no \
58         mutt_cv_c99_snprintf=yes \
59         mutt_cv_c99_vsnprintf=yes \
60         mutt_cv_regex_broken=no \
61         mutt_cv_worldwrite=yes \
62         mutt_cv_groupwrite=yes \
63         mutt_cv_iconv_good=yes \
64         mutt_cv_iconv_nontrans=no
65
66 MUTT_CONF_OPTS += --with-mailpath=/var/mail
67
68 define MUTT_VAR_MAIL
69         mkdir -p $(TARGET_DIR)/var
70         ln -sf /tmp $(TARGET_DIR)/var/mail
71 endef
72 MUTT_POST_INSTALL_TARGET_HOOKS += MUTT_VAR_MAIL
73
74 $(eval $(autotools-package))