]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/libinput/libinput.mk
libinput: fix variable name typo
[coffee/buildroot.git] / package / libinput / libinput.mk
1 ################################################################################
2 #
3 # libinput
4 #
5 ################################################################################
6
7 LIBINPUT_VERSION = 1.2.4
8 LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
9 LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
10 LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev
11 LIBINPUT_INSTALL_STAGING = YES
12 LIBINPUT_LICENSE = MIT
13 LIBINPUT_LICENSE_FILES = COPYING
14 # Tests need fork, so just disable them everywhere.
15 LIBINPUT_CONF_OPTS = --disable-tests --disable-libwacom
16
17 ifeq ($(BR2_PACKAGE_LIBGTK3),y)
18 LIBINPUT_CONF_OPTS += --enable-event-gui
19 LIBINPUT_DEPENDENCIES += libgtk3
20 else
21 LIBINPUT_CONF_OPTS += --disable-event-gui
22 endif
23
24 $(eval $(autotools-package))