]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/stress/stress.mk
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
[coffee/buildroot.git] / package / stress / stress.mk
1 ################################################################################
2 #
3 # stress
4 #
5 ################################################################################
6
7 STRESS_VERSION = 1.0.4
8 STRESS_SITE = http://people.seas.harvard.edu/~apw/stress
9 STRESS_LICENSE = GPLv2+
10 STRESS_LICENSE_FILES = COPYING
11 STRESS_AUTORECONF = YES
12
13 # Stress is linked statically if the --enable-static is specified.
14 # However, this option is always specified in the global
15 # SHARED_STATIC_LIBS_OPTS to tell packages to build static libraries,
16 # if supported.
17 #
18 # If the BR2_STATIC_LIBS is not defined, we have to specify
19 # --disable-static explicitly to get stress linked dynamically.
20 #
21 # Also, disable documentation by undefining makeinfo
22 STRESS_CONF_OPTS = \
23         $(if $(BR2_STATIC_LIBS),,--disable-static) \
24         MAKEINFO=:
25
26 $(eval $(autotools-package))