]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/slang/slang.mk
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
[coffee/buildroot.git] / package / slang / slang.mk
1 ################################################################################
2 #
3 # slang
4 #
5 ################################################################################
6
7 SLANG_VERSION = 2.3.0
8 SLANG_SITE = http://www.jedsoft.org/releases/slang/
9 SLANG_LICENSE = GPLv2+
10 SLANG_LICENSE_FILES = COPYING
11 SLANG_INSTALL_STAGING = YES
12 SLANG_MAKE = $(MAKE1)
13
14 # Racy and we don't have/do libtermcap
15 define SLANG_DISABLE_TERMCAP
16         $(SED) '/^TERMCAP=/s:=.*:=:' $(@D)/configure
17 endef
18 SLANG_POST_PATCH_HOOKS += SLANG_DISABLE_TERMCAP
19
20 # Absolute path hell, sigh...
21 ifeq ($(BR2_PACKAGE_LIBPNG),y)
22         SLANG_CONF_OPTS += --with-png=$(STAGING_DIR)/usr
23         SLANG_DEPENDENCIES += libpng
24 else
25         SLANG_CONF_OPTS += --with-png=no
26 endif
27 ifeq ($(BR2_PACKAGE_PCRE),y)
28         SLANG_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
29         SLANG_DEPENDENCIES += pcre
30 else
31         SLANG_CONF_OPTS += --with-pcre=no
32 endif
33 ifeq ($(BR2_PACKAGE_ZLIB),y)
34         SLANG_CONF_OPTS += --with-z=$(STAGING_DIR)/usr
35         SLANG_DEPENDENCIES += zlib
36 else
37         SLANG_CONF_OPTS += --with-z=no
38 endif
39
40 ifeq ($(BR2_PACKAGE_NCURSES),y)
41         SLANG_DEPENDENCIES += ncurses
42 else
43         SLANG_CONF_OPTS += ac_cv_path_nc5config=no
44 endif
45
46 ifeq ($(BR2_PACKAGE_READLINE),y)
47         SLANG_CONF_OPTS += --with-readline=gnu
48         SLANG_DEPENDENCIES += readline
49 endif
50
51 ifeq ($(BR2_STATIC_LIBS),y)
52         SLANG_MAKE_OPTS = static
53         SLANG_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-static
54         SLANG_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-static
55 endif
56
57 $(eval $(autotools-package))