]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/dhcpcd/dhcpcd.mk
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
[coffee/buildroot.git] / package / dhcpcd / dhcpcd.mk
1 ################################################################################
2 #
3 # dhcpcd
4 #
5 ################################################################################
6
7 DHCPCD_VERSION = 6.6.5
8 DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
9 DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd
10 DHCPCD_DEPENDENCIES = host-pkgconf
11 DHCPCD_LICENSE = BSD-2c
12
13 ifeq ($(BR2_INET_IPV6),)
14         DHCPCD_CONFIG_OPTS += --disable-ipv6
15 endif
16
17 ifeq ($(BR2_STATIC_LIBS),y)
18         DHCPCD_CONFIG_OPTS += --enable-static
19 endif
20
21 ifeq ($(BR2_USE_MMU),)
22         DHCPCD_CONFIG_OPTS += --disable-fork
23 endif
24
25 define DHCPCD_CONFIGURE_CMDS
26         (cd $(@D); \
27         $(TARGET_CONFIGURE_OPTS) ./configure \
28                 --os=linux \
29                 $(DHCPCD_CONFIG_OPTS) )
30 endef
31
32 define DHCPCD_BUILD_CMDS
33         $(TARGET_MAKE_ENV) $(MAKE) \
34                 -C $(@D) all
35 endef
36
37 define DHCPCD_INSTALL_TARGET_CMDS
38         $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install DESTDIR=$(TARGET_DIR)
39 endef
40
41 # NOTE: Even though this package has a configure script, it is not generated
42 # using the autotools, so we have to use the generic package infrastructure.
43
44 $(eval $(generic-package))