]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/czmq/czmq.mk
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
[coffee/buildroot.git] / package / czmq / czmq.mk
1 ################################################################################
2 #
3 # czmq
4 #
5 ################################################################################
6
7 CZMQ_VERSION = v3.0.0
8 CZMQ_SITE = $(call github,zeromq,czmq,$(CZMQ_VERSION))
9
10 # Autoreconf required as we use the git tree
11 CZMQ_AUTORECONF = YES
12 CZMQ_INSTALL_STAGING = YES
13 CZMQ_DEPENDENCIES = zeromq
14 CZMQ_LICENSE = MPLv2.0
15 CZMQ_LICENSE_FILES = LICENSE
16
17 # asciidoc is a python script that imports unicodedata, which is not in
18 # host-python, so disable asciidoc entirely.
19 CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
20
21 ifeq ($(BR2_STATIC_LIBS),y)
22 CZMQ_CONF_OPTS += LIBS="-lstdc++ -lm"
23 endif
24
25 define CZMQ_CREATE_CONFIG_DIR
26         mkdir -p $(@D)/config
27 endef
28
29 CZMQ_POST_PATCH_HOOKS += CZMQ_CREATE_CONFIG_DIR
30
31 $(eval $(autotools-package))