]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/openvpn/openvpn.mk
openvpn: bump to version 2.4.6
[coffee/buildroot.git] / package / openvpn / openvpn.mk
1 ################################################################################
2 #
3 # openvpn
4 #
5 ################################################################################
6
7 OPENVPN_VERSION = 2.4.6
8 OPENVPN_SOURCE = openvpn-$(OPENVPN_VERSION).tar.xz
9 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
10 OPENVPN_DEPENDENCIES = host-pkgconf openssl
11 OPENVPN_LICENSE = GPL-2.0
12 OPENVPN_LICENSE_FILES = COPYRIGHT.GPL
13 OPENVPN_CONF_OPTS = \
14         --disable-plugin-auth-pam \
15         --enable-iproute2 \
16         --with-crypto-library=openssl \
17         $(if $(BR2_STATIC_LIBS),--disable-plugins)
18 OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
19         NETSTAT=/bin/netstat \
20         ROUTE=/sbin/route \
21         IPROUTE=/sbin/ip
22
23 ifeq ($(BR2_PACKAGE_OPENVPN_SMALL),y)
24 OPENVPN_CONF_OPTS += \
25         --enable-small \
26         --disable-plugins
27 endif
28
29 ifeq ($(BR2_PACKAGE_OPENVPN_LZ4),y)
30 OPENVPN_DEPENDENCIES += lz4
31 else
32 OPENVPN_CONF_OPTS += --disable-lz4
33 endif
34
35 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
36 OPENVPN_DEPENDENCIES += lzo
37 else
38 OPENVPN_CONF_OPTS += --disable-lzo
39 endif
40
41 define OPENVPN_INSTALL_TARGET_CMDS
42         $(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
43                 $(TARGET_DIR)/usr/sbin/openvpn
44 endef
45
46 define OPENVPN_INSTALL_INIT_SYSV
47         $(INSTALL) -m 755 -D package/openvpn/S60openvpn \
48                 $(TARGET_DIR)/etc/init.d/S60openvpn
49 endef
50
51 $(eval $(autotools-package))