]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/msmtp/msmtp.mk
msmtp: add optional libidn dependency
[coffee/buildroot.git] / package / msmtp / msmtp.mk
1 ################################################################################
2 #
3 # msmtp
4 #
5 ################################################################################
6
7 MSMTP_VERSION = 1.6.6
8 MSMTP_SITE = http://downloads.sourceforge.net/project/msmtp/msmtp/$(MSMTP_VERSION)
9 MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
10 MSMTP_DEPENDENCIES = host-pkgconf
11 MSMTP_CONF_OPTS = --disable-gai-idn
12 MSMTP_LICENSE = GPL-3.0+
13 MSMTP_LICENSE_FILES = COPYING
14
15 ifeq ($(BR2_PACKAGE_LIBGSASL),y)
16 MSMTP_CONF_OPTS += --with-libgsasl
17 MSMTP_DEPENDENCIES += libgsasl
18 else
19 MSMTP_CONF_OPTS += --without-libgsasl
20 endif
21
22 ifeq ($(BR2_PACKAGE_LIBIDN),y)
23 MSMTP_CONF_OPTS += --with-libidn
24 MSMTP_DEPENDENCIES += libidn
25 else
26 MSMTP_CONF_OPTS += --without-libidn
27 endif
28
29 ifeq ($(BR2_PACKAGE_LIBSECRET),y)
30 MSMTP_CONF_OPTS += --with-libsecret
31 MSMTP_DEPENDENCIES += libsecret
32 else
33 MSMTP_CONF_OPTS += --without-libsecret
34 endif
35
36 ifeq ($(BR2_PACKAGE_OPENSSL),y)
37 MSMTP_CONF_OPTS += --with-ssl=openssl
38 MSMTP_DEPENDENCIES += openssl
39 ifeq ($(BR2_STATIC_LIBS),y)
40 # openssl uses zlib, so we need to explicitly link with it when static
41 MSMTP_CONF_ENV += LIBS=-lz
42 endif
43 else ifeq ($(BR2_PACKAGE_GNUTLS),y)
44 MSMTP_CONF_OPTS += --with-ssl=gnutls
45 MSMTP_DEPENDENCIES += gnutls
46 else
47 MSMTP_CONF_OPTS += --with-ssl=no
48 endif
49
50 $(eval $(autotools-package))