]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/linux-syscall-support/linux-syscall-support.mk
package/google-breakpad: bump to the latest version
[coffee/buildroot.git] / package / linux-syscall-support / linux-syscall-support.mk
1 ################################################################################
2 #
3 # linux-syscall-support
4 #
5 ################################################################################
6
7 # Use the same version that the one used by Google-breakpad (see DEPS file)
8 LINUX_SYSCALL_SUPPORT_VERSION = 3f6478ac95edf86cd3da300c2c0d34a438f5dbeb
9 LINUX_SYSCALL_SUPPORT_SITE = https://chromium.googlesource.com/linux-syscall-support
10 LINUX_SYSCALL_SUPPORT_SITE_METHOD = git
11 LINUX_SYSCALL_SUPPORT_LICENSE = BSD-3c
12 LINUX_SYSCALL_SUPPORT_LICENSE_FILES = linux_syscall_support.h
13
14 # Provide only one header file.
15 LINUX_SYSCALL_SUPPORT_INSTALL_TARGET = NO
16 LINUX_SYSCALL_SUPPORT_INSTALL_STAGING = YES
17
18 define LINUX_SYSCALL_SUPPORT_INSTALL_STAGING_CMDS
19         $(INSTALL) -D -m 0644 $(@D)/linux_syscall_support.h \
20                 $(STAGING_DIR)/usr/include/linux_syscall_support.h
21 endef
22
23 define HOST_LINUX_SYSCALL_SUPPORT_INSTALL_CMDS
24         $(INSTALL) -D -m 0644 $(@D)/linux_syscall_support.h \
25                 $(HOST_DIR)/usr/include/linux_syscall_support.h
26 endef
27
28 $(eval $(host-generic-package))
29 $(eval $(generic-package))