]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/google-breakpad/google-breakpad.mk
package/google-breakpad: bump to the latest version
[coffee/buildroot.git] / package / google-breakpad / google-breakpad.mk
1 ################################################################################
2 #
3 # google-breakpad
4 #
5 ################################################################################
6
7 GOOGLE_BREAKPAD_VERSION = 7515ab13768c7edc09f0f2ec2354dc6c928239a6
8 GOOGLE_BREAKPAD_SITE = https://chromium.googlesource.com/breakpad/breakpad
9 GOOGLE_BREAKPAD_SITE_METHOD = git
10 GOOGLE_BREAKPAD_CONF_OPTS = --disable-processor --disable-tools
11 # Only a static library is installed
12 GOOGLE_BREAKPAD_INSTALL_TARGET = NO
13 GOOGLE_BREAKPAD_INSTALL_STAGING = YES
14 GOOGLE_BREAKPAD_LICENSE = BSD-3c
15 GOOGLE_BREAKPAD_LICENSE_FILES = LICENSE
16 GOOGLE_BREAKPAD_DEPENDENCIES = host-google-breakpad linux-syscall-support
17
18 HOST_GOOGLE_BREAKPAD_DEPENDENCIES = host-linux-syscall-support 
19
20 # Avoid using depot-tools to download this file.
21 define HOST_GOOGLE_BREAKPAD_LSS
22         $(INSTALL) -D -m 0644 \
23                 $(HOST_DIR)/usr/include/linux_syscall_support.h \
24                 $(@D)/src/third_party/lss/linux_syscall_support.h
25 endef
26 HOST_GOOGLE_BREAKPAD_POST_EXTRACT_HOOKS += HOST_GOOGLE_BREAKPAD_LSS
27
28 define GOOGLE_BREAKPAD_LSS
29         $(INSTALL) -D -m 0644 \
30                 $(STAGING_DIR)/usr/include/linux_syscall_support.h \
31                 $(@D)/src/third_party/lss/linux_syscall_support.h
32 endef
33 GOOGLE_BREAKPAD_POST_EXTRACT_HOOKS += GOOGLE_BREAKPAD_LSS
34
35 define GOOGLE_BREAKPAD_EXTRACT_SYMBOLS
36         $(EXTRA_ENV) package/google-breakpad/gen-syms.sh $(STAGING_DIR) \
37                 $(TARGET_DIR) $(call qstrip,$(BR2_GOOGLE_BREAKPAD_INCLUDE_FILES))
38 endef
39 GOOGLE_BREAKPAD_TARGET_FINALIZE_HOOKS += GOOGLE_BREAKPAD_EXTRACT_SYMBOLS
40
41 $(eval $(autotools-package))
42 $(eval $(host-autotools-package))