]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/ncftp/ncftp.mk
ncftp: fix cross-compilation test
[coffee/buildroot.git] / package / ncftp / ncftp.mk
1 ################################################################################
2 #
3 # ncftp
4 #
5 ################################################################################
6
7 NCFTP_VERSION = 3.2.5
8 NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.bz2
9 NCFTP_SITE = ftp://ftp.ncftp.com/ncftp
10 NCFTP_TARGET_BINS = ncftp
11 NCFTP_LICENSE = Clarified Artistic License
12 NCFTP_LICENSE_FILES = doc/LICENSE.txt
13
14 NCFTP_DEPENDENCIES = host-autoconf
15
16 define NCFTP_RUN_AUTOCONF
17        (cd $(@D); $(HOST_DIR)/usr/bin/autoconf -I$(@D)/autoconf_local/)
18 endef
19
20 NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
21
22 ifeq ($(BR2_PACKAGE_NCFTP_GET),y)
23         NCFTP_TARGET_BINS += ncftpget
24 endif
25
26 ifeq ($(BR2_PACKAGE_NCFTP_PUT),y)
27         NCFTP_TARGET_BINS += ncftpput
28 endif
29
30 ifeq ($(BR2_PACKAGE_NCFTP_LS),y)
31         NCFTP_TARGET_BINS += ncftpls
32 endif
33
34 ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
35         NCFTP_TARGET_BINS += ncftpbatch
36         NCFTP_INSTALL_NCFTP_BATCH = \
37                 ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
38 endif
39
40 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
41         NCFTP_TARGET_BINS += ncftpbookmarks
42         NCFTP_DEPENDENCIES += ncurses
43 endif
44
45 define NCFTP_INSTALL_TARGET_CMDS
46         $(INSTALL) -m 0755 $(addprefix $(NCFTP_DIR)/bin/, $(NCFTP_TARGET_BINS)) $(TARGET_DIR)/usr/bin
47         $(NCFTP_INSTALL_NCFTP_BATCH)
48 endef
49
50 $(eval $(autotools-package))