]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/irssi/irssi.mk
irssi: security bump to version 1.0.7
[coffee/buildroot.git] / package / irssi / irssi.mk
1 ################################################################################
2 #
3 # irssi
4 #
5 ################################################################################
6
7 IRSSI_VERSION = 1.0.7
8 IRSSI_SOURCE = irssi-$(IRSSI_VERSION).tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE = https://github.com/irssi/irssi/releases/download/$(IRSSI_VERSION)
12 IRSSI_LICENSE = GPL-2.0+
13 IRSSI_LICENSE_FILES = COPYING
14 IRSSI_DEPENDENCIES = host-pkgconf libglib2 ncurses openssl
15
16 IRSSI_CONF_OPTS = \
17         --disable-glibtest \
18         --without-perl
19
20 ifeq ($(BR2_PACKAGE_IRSSI_PROXY),y)
21 IRSSI_CONF_OPTS += --with-proxy
22 # If shared libs are disabled, 'proxy' has to go in the list of built-in
23 # modules.
24 ifeq ($(BR2_STATIC_LIBS),y)
25 IRSSI_CONF_OPTS += --with-modules=proxy
26 endif
27 else
28 IRSSI_CONF_OPTS += --without-proxy
29 endif # proxy
30
31 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR),y)
32 IRSSI_CONF_OPTS += --enable-true-color
33 else
34 IRSSI_CONF_OPTS += --disable-true-color
35 endif
36
37 # Cross-compiling irssi with the perl interpreter enabled doesn't work
38 # yet. So, remove scripts as they are useless in that case.
39 define IRSSI_REMOVE_SCRIPTS
40         rm -rf $(TARGET_DIR)/usr/share/irssi/scripts/
41 endef
42
43 IRSSI_POST_INSTALL_TARGET_HOOKS += IRSSI_REMOVE_SCRIPTS
44
45 $(eval $(autotools-package))