]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/python-lxml/python-lxml.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / python-lxml / python-lxml.mk
1 ################################################################################
2 #
3 # python-lxml
4 #
5 ################################################################################
6
7 PYTHON_LXML_VERSION = 3.7.2
8 PYTHON_LXML_SITE = http://lxml.de/files
9 PYTHON_LXML_SOURCE = lxml-$(PYTHON_LXML_VERSION).tgz
10
11 # Not including the GPL, because it is used only for the test scripts.
12 PYTHON_LXML_LICENSE = BSD-3-Clause, Others
13 PYTHON_LXML_LICENSE_FILES = \
14         LICENSES.txt \
15         doc/licenses/BSD.txt \
16         doc/licenses/elementtree.txt \
17         src/lxml/isoschematron/resources/rng/iso-schematron.rng
18
19 # python-lxml can use either setuptools, or distutils as a fallback.
20 # So, we use setuptools.
21 PYTHON_LXML_SETUP_TYPE = setuptools
22
23 PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
24 HOST_PYTHON_LXML_DEPENDENCIES = host-libxml2 host-libxslt host-zlib
25
26 # python-lxml needs these scripts in order to properly detect libxml2 and
27 # libxslt compiler and linker flags
28 PYTHON_LXML_BUILD_OPTS = \
29         --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
30         --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
31 HOST_PYTHON_LXML_BUILD_OPTS = \
32         --with-xslt-config=$(HOST_DIR)/bin/xslt-config \
33         --with-xml2-config=$(HOST_DIR)/bin/xml2-config
34
35 $(eval $(python-package))
36 $(eval $(host-python-package))