]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/php-gnupg/php-gnupg.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / php-gnupg / php-gnupg.mk
1 ################################################################################
2 #
3 # php-gnupg
4 #
5 ################################################################################
6
7 PHP_GNUPG_VERSION = 1.4.0
8 PHP_GNUPG_SOURCE = gnupg-$(PHP_GNUPG_VERSION).tgz
9 PHP_GNUPG_SITE = https://pecl.php.net/get
10 # phpize does the autoconf magic
11 PHP_GNUPG_DEPENDENCIES = php libgpgme host-autoconf host-pkgconf
12 PHP_GNUPG_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
13         --with-gnupg=$(STAGING_DIR)/usr/include --with-gpg=/usr/bin/gpg
14 PHP_GNUPG_LICENSE = BSD-2-Clause
15 PHP_GNUPG_LICENSE_FILES = LICENSE
16
17 define PHP_GNUPG_PHPIZE
18         (cd $(@D); \
19                 PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
20                 PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
21                 $(STAGING_DIR)/usr/bin/phpize)
22 endef
23
24 PHP_GNUPG_PRE_CONFIGURE_HOOKS += PHP_GNUPG_PHPIZE
25
26 $(eval $(autotools-package))