]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/directfb/directfb.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / directfb / directfb.mk
1 ################################################################################
2 #
3 # directfb
4 #
5 ################################################################################
6
7 DIRECTFB_VERSION_MAJOR = 1.7
8 DIRECTFB_VERSION = $(DIRECTFB_VERSION_MAJOR).7
9 DIRECTFB_SITE = http://www.directfb.org/downloads/Core/DirectFB-$(DIRECTFB_VERSION_MAJOR)
10 DIRECTFB_SOURCE = DirectFB-$(DIRECTFB_VERSION).tar.gz
11 DIRECTFB_LICENSE = LGPL-2.1+
12 DIRECTFB_LICENSE_FILES = COPYING
13 DIRECTFB_INSTALL_STAGING = YES
14 DIRECTFB_AUTORECONF = YES
15
16 DIRECTFB_CONF_OPTS = \
17         --enable-zlib \
18         --enable-freetype \
19         --enable-fbdev \
20         --disable-sdl \
21         --disable-vnc \
22         --disable-osx \
23         --disable-video4linux \
24         --disable-video4linux2 \
25         --without-tools \
26         --disable-x11
27
28 ifeq ($(BR2_STATIC_LIBS),y)
29 DIRECTFB_CONF_OPTS += --disable-dynload
30 endif
31
32 DIRECTFB_CONFIG_SCRIPTS = directfb-config
33
34 DIRECTFB_DEPENDENCIES = freetype zlib
35
36 ifeq ($(BR2_PACKAGE_DIRECTFB_MULTI),y)
37 DIRECTFB_CONF_OPTS += --enable-multi --enable-multi-kernel
38 DIRECTFB_DEPENDENCIES += linux-fusion
39 else
40 DIRECTFB_CONF_OPTS += --disable-multi --disable-multi-kernel
41 endif
42
43 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT),y)
44 DIRECTFB_CONF_OPTS += --enable-debug-support
45 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG),y)
46 DIRECTFB_CONF_OPTS += --enable-debug
47 endif
48 else
49 DIRECTFB_CONF_OPTS += --disable-debug-support
50 endif
51
52 ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE),y)
53 DIRECTFB_CONF_OPTS += --enable-trace
54 endif
55
56 ifeq ($(BR2_PACKAGE_DIRECTFB_DIVINE),y)
57 DIRECTFB_CONF_OPTS += --enable-divine
58 else
59 DIRECTFB_CONF_OPTS += --disable-divine
60 endif
61
62 ifeq ($(BR2_PACKAGE_DIRECTFB_SAWMAN),y)
63 DIRECTFB_CONF_OPTS += --enable-sawman
64 else
65 DIRECTFB_CONF_OPTS += --disable-sawman
66 endif
67
68 DIRECTFB_GFX = \
69         $(if $(BR2_PACKAGE_DIRECTFB_ATI128),ati128) \
70         $(if $(BR2_PACKAGE_DIRECTFB_CYBER5K),cyber5k) \
71         $(if $(BR2_PACKAGE_DIRECTFB_MATROX),matrox) \
72         $(if $(BR2_PACKAGE_DIRECTFB_PXA3XX),pxa3xx) \
73         $(if $(BR2_PACKAGE_DIRECTFB_I830),i830) \
74         $(if $(BR2_PACKAGE_DIRECTFB_EP9X),ep9x)
75
76 ifeq ($(strip $(DIRECTFB_GFX)),)
77 DIRECTFB_CONF_OPTS += --with-gfxdrivers=none
78 else
79 DIRECTFB_CONF_OPTS += \
80         --with-gfxdrivers=$(subst $(space),$(comma),$(strip $(DIRECTFB_GFX)))
81 endif
82
83 DIRECTFB_INPUT = \
84         $(if $(BR2_PACKAGE_DIRECTFB_LINUXINPUT),linuxinput) \
85         $(if $(BR2_PACKAGE_DIRECTFB_KEYBOARD),keyboard) \
86         $(if $(BR2_PACKAGE_DIRECTFB_PS2MOUSE),ps2mouse) \
87         $(if $(BR2_PACKAGE_DIRECTFB_SERIALMOUSE),serialmouse) \
88         $(if $(BR2_PACKAGE_DIRECTFB_TSLIB),tslib)
89
90 ifeq ($(BR2_PACKAGE_DIRECTFB_TSLIB),y)
91 DIRECTFB_DEPENDENCIES += tslib
92 endif
93
94 ifeq ($(strip $(DIRECTFB_INPUT)),)
95 DIRECTFB_CONF_OPTS += --with-inputdrivers=none
96 else
97 DIRECTFB_CONF_OPTS += \
98         --with-inputdrivers=$(subst $(space),$(comma),$(strip $(DIRECTFB_INPUT)))
99 endif
100
101 ifeq ($(BR2_PACKAGE_DIRECTFB_GIF),y)
102 DIRECTFB_CONF_OPTS += --enable-gif
103 else
104 DIRECTFB_CONF_OPTS += --disable-gif
105 endif
106
107 ifeq ($(BR2_PACKAGE_DIRECTFB_TIFF),y)
108 DIRECTFB_CONF_OPTS += --enable-tiff
109 DIRECTFB_DEPENDENCIES += tiff
110 else
111 DIRECTFB_CONF_OPTS += --disable-tiff
112 endif
113
114 ifeq ($(BR2_PACKAGE_DIRECTFB_PNG),y)
115 DIRECTFB_CONF_OPTS += --enable-png
116 DIRECTFB_DEPENDENCIES += libpng
117 DIRECTFB_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
118 else
119 DIRECTFB_CONF_OPTS += --disable-png
120 endif
121
122 ifeq ($(BR2_PACKAGE_DIRECTFB_JPEG),y)
123 DIRECTFB_CONF_OPTS += --enable-jpeg
124 DIRECTFB_DEPENDENCIES += jpeg
125 else
126 DIRECTFB_CONF_OPTS += --disable-jpeg
127 endif
128
129 ifeq ($(BR2_PACKAGE_DIRECTFB_SVG),y)
130 DIRECTFB_CONF_OPTS += --enable-svg
131 # needs some help to find cairo includes
132 DIRECTFB_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/cairo"
133 DIRECTFB_DEPENDENCIES += libsvg-cairo
134 else
135 DIRECTFB_CONF_OPTS += --disable-svg
136 endif
137
138 ifeq ($(BR2_PACKAGE_DIRECTFB_IMLIB2),y)
139 DIRECTFB_CONF_OPTS += --enable-imlib2
140 DIRECTFB_DEPENDENCIES += imlib2
141 DIRECTFB_CONF_ENV += ac_cv_path_IMLIB2_CONFIG=$(STAGING_DIR)/usr/bin/imlib2-config
142 else
143 DIRECTFB_CONF_OPTS += --disable-imlib2
144 endif
145
146 ifeq ($(BR2_PACKAGE_DIRECTFB_DITHER_RGB16),y)
147 DIRECTFB_CONF_OPTS += --with-dither-rgb16=advanced
148 else
149 DIRECTFB_CONF_OPTS += --with-dither-rgb16=none
150 endif
151
152 ifeq ($(BR2_PACKAGE_DIRECTFB_TESTS),y)
153 DIRECTFB_CONF_OPTS += --with-tests
154 endif
155
156 HOST_DIRECTFB_DEPENDENCIES = host-pkgconf host-libpng
157 HOST_DIRECTFB_CONF_OPTS = \
158         --disable-multi \
159         --enable-png \
160         --with-gfxdrivers=none \
161         --with-inputdrivers=none
162
163 HOST_DIRECTFB_BUILD_CMDS = \
164         $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/tools directfb-csource
165
166 HOST_DIRECTFB_INSTALL_CMDS = \
167         $(INSTALL) -m 0755 $(@D)/tools/directfb-csource $(HOST_DIR)/bin
168
169 $(eval $(autotools-package))
170 $(eval $(host-autotools-package))
171
172 # directfb-csource for the host
173 DIRECTFB_HOST_BINARY = $(HOST_DIR)/bin/directfb-csource