]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/python-setuptools/python-setuptools.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / python-setuptools / python-setuptools.mk
1 ################################################################################
2 #
3 # python-setuptools
4 #
5 ################################################################################
6
7 PYTHON_SETUPTOOLS_VERSION = v36.0.1
8 PYTHON_SETUPTOOLS_SITE = $(call github,pypa,setuptools,$(PYTHON_SETUPTOOLS_VERSION))
9 PYTHON_SETUPTOOLS_LICENSE = MIT
10 PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
11 PYTHON_SETUPTOOLS_SETUP_TYPE = setuptools
12
13 # recent setuptools versions require bootstrap.py to be invoked
14 # before the standard setup process.
15 define PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
16         cd  $(@D) && $(HOST_DIR)/bin/python ./bootstrap.py
17 endef
18
19 PYTHON_SETUPTOOLS_PRE_CONFIGURE_HOOKS = PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
20 HOST_PYTHON_SETUPTOOLS_PRE_CONFIGURE_HOOKS = PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
21
22 $(eval $(python-package))
23 $(eval $(host-python-package))