]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/php-memcached/php-memcached.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / php-memcached / php-memcached.mk
1 ################################################################################
2 #
3 # php-memcached
4 #
5 ################################################################################
6
7 PHP_MEMCACHED_VERSION = 3.0.3
8 PHP_MEMCACHED_SOURCE = memcached-$(PHP_MEMCACHED_VERSION).tgz
9 PHP_MEMCACHED_SITE = https://pecl.php.net/get
10 PHP_MEMCACHED_CONF_OPTS = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
11         --disable-memcached-sasl \
12         --with-libmemcached-dir=$(STAGING_DIR)/usr \
13         --with-zlib-dir=$(STAGING_DIR)/usr
14 # phpize does the autoconf magic
15 PHP_MEMCACHED_DEPENDENCIES = libmemcached php zlib host-autoconf host-pkgconf
16 PHP_MEMCACHED_LICENSE = PHP-3.01, MIT (fastlz), ISC-like (g_fmt.c, g_fmt.h)
17 PHP_MEMCACHED_LICENSE_FILES = LICENSE fastlz/LICENSE g_fmt.h
18
19 define PHP_MEMCACHED_PHPIZE
20         (cd $(@D); \
21                 PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
22                 PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
23                 $(STAGING_DIR)/usr/bin/phpize)
24 endef
25
26 PHP_MEMCACHED_PRE_CONFIGURE_HOOKS += PHP_MEMCACHED_PHPIZE
27
28 $(eval $(autotools-package))