]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/protobuf/protobuf.mk
package: remove the default value of the $(PKG)_SOURCE variable
[coffee/buildroot.git] / package / protobuf / protobuf.mk
1 ################################################################################
2 #
3 # protobuf
4 #
5 ################################################################################
6
7 PROTOBUF_VERSION = 2.4.1
8 PROTOBUF_SITE = http://protobuf.googlecode.com/files/
9 PROTOBUF_LICENSE = BSD-3c
10 PROTOBUF_LICENSE_FILES = COPYING.txt
11
12 # N.B. Need to use host protoc during cross compilation.
13 PROTOBUF_DEPENDENCIES = host-protobuf
14 PROTOBUF_CONF_OPT = --with-protoc=$(HOST_DIR)/usr/bin/protoc
15
16 PROTOBUF_INSTALL_STAGING = YES
17
18 ifeq ($(BR2_PACKAGE_ZLIB),y)
19 PROTOBUF_DEPENDENCIES += zlib
20 endif
21
22 $(eval $(autotools-package))
23 $(eval $(host-autotools-package))