]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/python-bottle/python-bottle.mk
python-bottle: new package
[coffee/buildroot.git] / package / python-bottle / python-bottle.mk
1 #############################################################
2 #
3 # python-bottle
4 #
5 #############################################################
6
7 PYTHON_BOTTLE_VERSION = 0.11.4
8 PYTHON_BOTTLE_SOURCE = bottle-$(PYTHON_BOTTLE_VERSION).tar.gz
9 PYTHON_BOTTLE_SITE = http://pypi.python.org/packages/source/b/bottle
10 PYTHON_BOTTLE_DEPENDENCIES = python
11 PYTHON_BOTTLE_LICENSE = MIT
12 # README.rst refers to the file "LICENSE" but it's not included
13
14 define PYTHON_BOTTLE_BUILD_CMDS
15         (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
16 endef
17
18 define PYTHON_BOTTLE_INSTALL_TARGET_CMDS
19         (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
20 endef
21
22 $(eval $(generic-package))