]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blob - package/tinc/tinc.mk
woff2: fix build on m68k
[coffee/buildroot.git] / package / tinc / tinc.mk
1 ################################################################################
2 #
3 # tinc
4 #
5 ################################################################################
6
7 TINC_VERSION = 1.0.33
8 TINC_SITE = http://www.tinc-vpn.org/packages
9 TINC_DEPENDENCIES = lzo openssl zlib
10 TINC_LICENSE = GPL-2.0+ with OpenSSL exception
11 TINC_LICENSE_FILES = COPYING COPYING.README
12 TINC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=c99"
13
14 ifeq ($(BR2_TOOLCHAIN_SUPPORTS_PIE),)
15 TINC_CONF_ENV += \
16         ax_cv_check_cflags___fPIE=no \
17         ax_cv_check_ldflags___pie=no
18 endif
19
20 ifeq ($(BR2_INIT_SYSTEMD),y)
21 TINC_DEPENDENCIES += systemd
22 TINC_CONF_OPTS += --with-systemdsystemunitdir=/usr/lib/systemd/system
23 endif
24
25 $(eval $(autotools-package))