]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
nix: Update flake inputs
[novaboot.git] / shell.nix
index 3c2334908c2a0f79a785992d00ae442cf1f79c8d..db84e3d07dd404a49131d2096ea59ce8daa363c5 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,3 @@
-{ pkgs ? import <nixpkgs> {} }:
-with pkgs;
-mkShell {
-  # this will make all the build inputs from hello and gnutar
-  # available to the shell environment
-  buildInputs = [ (perl.withPackages (p: [ p.PodParser ])) ];
-}
+(import (fetchTarball https://github.com/edolstra/flake-compat/archive/master.tar.gz) {
+  src = builtins.fetchGit ./.;
+}).shellNix