]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
nix: Switch from lorri to "use nix"
[novaboot.git] / shell.nix
index e1641fd61dab0749ae249da414ca049b51bb1d6f..db84e3d07dd404a49131d2096ea59ce8daa363c5 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,14 +1,3 @@
-{ pkgs ? import <nixpkgs> {} }:
-with pkgs;
-mkShell {
-  inputsFrom = [
-    (import ./default.nix {
-      inherit pkgs;
-      otherPerlPackages = [ perl.pkgs.PodParser ];
-    }).novaboot
-  ];
-  buildInputs = with pkgs; [
-    syslinux
-    cdrkit
-  ];
-}
+(import (fetchTarball https://github.com/edolstra/flake-compat/archive/master.tar.gz) {
+  src = builtins.fetchGit ./.;
+}).shellNix