]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
nix: Convert to flakes
[novaboot.git] / shell.nix
index 0cdacc477f564693ecac8d7138e716e59acfb1b4..db84e3d07dd404a49131d2096ea59ce8daa363c5 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,16 +1,3 @@
-{ pkgs ? import <nixpkgs> {} }:
-with pkgs;
-mkShell {
-  inputsFrom = [
-    (import ./default.nix {
-      inherit pkgs;
-      otherPerlPackages = [ perl.pkgs.PodParser ];
-    }).novaboot
-  ];
-  buildInputs = with pkgs; [
-    syslinux
-    cdrkit
-    grub2
-    dhcp
-  ];
-}
+(import (fetchTarball https://github.com/edolstra/flake-compat/archive/master.tar.gz) {
+  src = builtins.fetchGit ./.;
+}).shellNix