]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/matchbox-fakekey/matchbox-fakekey.mk
package/matchbox-lib: correctly fix the .pc file
[coffee/buildroot.git] / package / matchbox-fakekey / matchbox-fakekey.mk
index ea8e6dcd61ccaf277e4f7792378dd9b7e609dfc9..d694e61c12ad1b917c285ca14962cc70c5d506e3 100644 (file)
@@ -14,8 +14,8 @@ MATCHBOX_FAKEKEY_DEPENDENCIES = matchbox-lib xlib_libXtst
 MATCHBOX_FAKEKEY_CONF_OPTS = --enable-expat
 
 define MATCHBOX_FAKEKEY_POST_CONFIGURE_FIXES
-       $(SED) 's:-I[^$$].*/usr/include/freetype2:-I/usr/include/freetype2:' $(STAGING_DIR)/usr/lib/pkgconfig/libmb.pc
-       $(SED) 's:^SUBDIRS = fakekey src tests.*:SUBDIRS = fakekey src:g' $(MATCHBOX_FAKEKEY_DIR)/Makefile
+       $(SED) 's:^SUBDIRS = fakekey src tests.*:SUBDIRS = fakekey src:g' \
+               $(@D)/Makefile
 endef
 
 MATCHBOX_FAKEKEY_POST_CONFIGURE_HOOKS += MATCHBOX_FAKEKEY_POST_CONFIGURE_FIXES