]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/openocd/openocd.mk
package/openocd: fix fallout after no-C++ fixups
[coffee/buildroot.git] / package / openocd / openocd.mk
index 9d2576ceeb95f5ebaafc61370f8482499d6dbc5a..548d8b81a0f3de04f71339a725381ac41ee3f293 100644 (file)
@@ -11,7 +11,12 @@ OPENOCD_LICENSE = GPL-2.0+
 OPENOCD_LICENSE_FILES = COPYING
 # 0002-configure-enable-build-on-uclinux.patch patches configure.ac
 OPENOCD_AUTORECONF = YES
-OPENOCD_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
+
+# The bundled jimtcl really wants to find a existing $CXX, so feed it
+# false when we do not have one.
+OPENOCD_CONF_ENV = \
+       $(if $(BR2_INSTALL_LIBSTDCPP),,CXX=false) \
+       CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
 
 OPENOCD_CONF_OPTS = \
        --oldincludedir=$(STAGING_DIR)/usr/include \