]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/clamav/clamav.mk
package/clamav: needs libtool
[coffee/buildroot.git] / package / clamav / clamav.mk
index 16178cd1f1a233a11b1346b230d6b29fbf9ec976..86bdda49e2661e0b1bee71ad003bd7c27d08f782 100644 (file)
@@ -4,14 +4,15 @@
 #
 ################################################################################
 
-CLAMAV_VERSION = 0.99.1
-CLAMAV_SITE = http://sourceforge.net/projects/clamav/files/clamav/$(CLAMAV_VERSION)
+CLAMAV_VERSION = 0.99.2
+CLAMAV_SITE = https://www.clamav.net/downloads/production
 CLAMAV_LICENSE = GPLv2
 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
        COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
        COPYING.unrar COPYING.zlib
 CLAMAV_DEPENDENCIES = \
        host-pkgconf \
+       libtool \
        openssl \
        zlib \
        $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
@@ -24,8 +25,11 @@ CLAMAV_CONF_ENV = \
 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
 CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \
+       --with-ltdl-include=$(STAGING_DIR)/usr/include \
+       --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
        --with-openssl=$(STAGING_DIR)/usr \
        --with-zlib=$(STAGING_DIR)/usr \
+       --disable-zlib-vcheck \
        --disable-rpath \
        --disable-clamav \
        --disable-fanotify \