]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/mesa3d-headers/mesa3d-headers.mk
package/{mesa3d, mesa3d-headers}: bump version to 17.3.5
[coffee/buildroot.git] / package / mesa3d-headers / mesa3d-headers.mk
index 5cad42d238529a0553991ee1cc15a96af0885daf..4c1353ac7a7083eb402657bbfde2bf729a835800 100644 (file)
@@ -12,9 +12,9 @@ endif
 
 # Not possible to directly refer to mesa3d variables, because of
 # first/second expansion trickery...
-MESA3D_HEADERS_VERSION = 11.1.2
+MESA3D_HEADERS_VERSION = 17.3.5
 MESA3D_HEADERS_SOURCE = mesa-$(MESA3D_HEADERS_VERSION).tar.xz
-MESA3D_HEADERS_SITE = ftp://ftp.freedesktop.org/pub/mesa/$(MESA3D_HEADERS_VERSION)
+MESA3D_HEADERS_SITE = https://mesa.freedesktop.org/archive
 MESA3D_HEADERS_LICENSE = MIT, SGI, Khronos
 MESA3D_HEADERS_LICENSE_FILES = docs/license.html
 
@@ -47,7 +47,7 @@ define MESA3D_HEADERS_INSTALL_DRI_PC
        $(INSTALL) -D -m 0644 $(@D)/include/GL/internal/dri_interface.h \
                $(STAGING_DIR)/usr/include/GL/internal/dri_interface.h
        $(INSTALL) -D -m 0644 $(@D)/src/mesa/drivers/dri/dri.pc \
-               $(STAGING_DIR)/usr/lib/pkg-config/dri.pc
+               $(STAGING_DIR)/usr/lib/pkgconfig/dri.pc
 endef
 
 endif # Xorg
@@ -62,10 +62,6 @@ ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
 MESA3D_HEADERS_DIRS += GLES GLES2
 endif
 
-ifeq ($(BR2_PACKAGE_HAS_LIBOPENVG),y)
-MESA3D_HEADERS_DIRS += VG
-endif
-
 define MESA3D_HEADERS_BUILD_CMDS
        $(MESA3D_HEADERS_BUILD_DRI_PC)
 endef