]> rtime.felk.cvut.cz Git - CanFestival-3.git/blobdiff - debian/canfestival-virtual.postinst
updated : debian package scripts
[CanFestival-3.git] / debian / canfestival-virtual.postinst
diff --git a/debian/canfestival-virtual.postinst b/debian/canfestival-virtual.postinst
new file mode 100755 (executable)
index 0000000..bafaa3b
--- /dev/null
@@ -0,0 +1,53 @@
+#!/bin/sh
+# postinst script for canfestival
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <postinst> `abort-remove'
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+DLL_LIST=
+CF_CONFIG=/usr/share/CanFestival-3/objdictgen/canfestival_config.py
+CF_CONFIG_TEMP=/usr/share/CanFestival-3/objdictgen/canfestival_config_ori.py
+case "$1" in
+    configure)
+    ldconfig
+    cd /usr/lib
+    DLL_LIST=
+       FILES=
+       for file in libcanfestival_can*
+       do
+               DLL_LIST="$file,""$DLL_LIST"
+       done
+       cat $CF_CONFIG_TEMP > $CF_CONFIG
+       echo "DLL_LIST=[$DLL_LIST]" >> $CF_CONFIG
+       ;;
+       
+    abort-upgrade|abort-remove|abort-deconfigure)
+    ;;
+
+    *)
+        echo "postinst called with unknown argument \`$1'" >&2
+        exit 1
+    ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+