]> rtime.felk.cvut.cz Git - sojka/debian/lightdm.git/blobdiff - debian/patches/03_quit-plymouth.patch
* debian/patches:
[sojka/debian/lightdm.git] / debian / patches / 03_quit-plymouth.patch
index b2e97eec7993c79bc3b16c43b804b16efb38ccb9..6a05142f61881639eae2b38c041f6e07e9b4ea48 100644 (file)
@@ -4,16 +4,14 @@ plymouth is quitted from the /etc/init.d/plymouth script, but it'll hang if
 plymouth has been deactivated before, so just quit it for now.
 Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=632737
 Bug: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/799069
-diff --git a/src/display-manager.c b/src/display-manager.c
-index c8f5f32..5191fcc 100644
---- a/src/display-manager.c
-+++ b/src/display-manager.c
-@@ -616,7 +616,7 @@ display_manager_start (DisplayManager *manager)
-         plymouth_on_active_vt = plymouth_command_returns_true ("--has-active-vt");
-         /* Deactivate stops Plymouth from drawing, as we are about to start an X server to replace it */
--        plymouth_run_command ("deactivate", NULL);
-+        plymouth_run_command ("quit", NULL);
-     }
-     /* Start each static display */
+--- a/src/xserver-local.c
++++ b/src/xserver-local.c
+@@ -142,7 +142,7 @@ xserver_local_new (void)
+             g_debug ("X server %s will replace Plymouth", xserver_get_address (XSERVER (self)));
+             self->priv->replacing_plymouth = TRUE;
+             self->priv->vt = active_vt;
+-            plymouth_deactivate ();
++            plymouth_quit (FALSE);
+         }
+         else
+             g_debug ("Plymouth is running on VT %d, but this is less than the configured minimum of %d so not replacing it", active_vt, vt_get_min ());