]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
grub2: Don't perform unnecessary config modifications for the linux BOOT_METHOD
[novaboot.git] / shell.nix
index a3ee325ddc54f2928a2656237535d55511bc7f84..e1641fd61dab0749ae249da414ca049b51bb1d6f 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,14 @@
 { pkgs ? import <nixpkgs> {} }:
 with pkgs;
 mkShell {
-  inputsFrom = [ (import ./default.nix { inherit pkgs; }).novaboot ];
-  buildInputs = [ (perl.withPackages (p: [ p.PodParser ])) ];
+  inputsFrom = [
+    (import ./default.nix {
+      inherit pkgs;
+      otherPerlPackages = [ perl.pkgs.PodParser ];
+    }).novaboot
+  ];
+  buildInputs = with pkgs; [
+    syslinux
+    cdrkit
+  ];
 }