]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
nix: Allow running (at least a part of) test suite from nix-shell
[novaboot.git] / shell.nix
index 3c2334908c2a0f79a785992d00ae442cf1f79c8d..a3ee325ddc54f2928a2656237535d55511bc7f84 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,6 @@
 { pkgs ? import <nixpkgs> {} }:
 with pkgs;
 mkShell {
-  # this will make all the build inputs from hello and gnutar
-  # available to the shell environment
+  inputsFrom = [ (import ./default.nix { inherit pkgs; }).novaboot ];
   buildInputs = [ (perl.withPackages (p: [ p.PodParser ])) ];
 }