]> rtime.felk.cvut.cz Git - novaboot.git/blobdiff - shell.nix
tests: Skip server tests during Debian package build
[novaboot.git] / shell.nix
index 3c2334908c2a0f79a785992d00ae442cf1f79c8d..e1641fd61dab0749ae249da414ca049b51bb1d6f 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,14 @@
 { pkgs ? import <nixpkgs> {} }:
 with pkgs;
 mkShell {
-  # this will make all the build inputs from hello and gnutar
-  # available to the shell environment
-  buildInputs = [ (perl.withPackages (p: [ p.PodParser ])) ];
+  inputsFrom = [
+    (import ./default.nix {
+      inherit pkgs;
+      otherPerlPackages = [ perl.pkgs.PodParser ];
+    }).novaboot
+  ];
+  buildInputs = with pkgs; [
+    syslinux
+    cdrkit
+  ];
 }