]> rtime.felk.cvut.cz Git - hercules2020/hercules-compiler.git/blobdiff - debian/patches/cuda_arch.patch
Configure clang via cmake options rather than via modifying sources
[hercules2020/hercules-compiler.git] / debian / patches / cuda_arch.patch
diff --git a/debian/patches/cuda_arch.patch b/debian/patches/cuda_arch.patch
deleted file mode 100644 (file)
index 842e368..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: Configuration for TX2 according to D33CompilerRuntime.docx 
-
---- a/openmp/libomptarget/deviceRTLs/nvptx/CMakeLists.txt
-+++ b/openmp/libomptarget/deviceRTLs/nvptx/CMakeLists.txt
-@@ -66,7 +66,7 @@
-       set(CUDA_ARCH ${CUDA_ARCH} -gencode arch=compute_${sm},code=sm_${sm})
-     endforeach()
-   else()
--    set(CUDA_ARCH -arch sm_35)
-+    set(CUDA_ARCH -arch sm_62)
-   endif()
-   
-   # Activate RTL message dumps if requested by the user.
-@@ -176,7 +176,7 @@
-           set(CUDA_ARCH ${CUDA_ARCH} --cuda-gpu-arch=sm_${sm})
-         endforeach()
-       else()
--        set(CUDA_ARCH --cuda-gpu-arch=sm_35)
-+        set(CUDA_ARCH --cuda-gpu-arch=sm_62)
-       endif()
-       # Compile cuda files to bitcode.
---- a/clang/lib/Driver/ToolChains.cpp
-+++ b/clang/lib/Driver/ToolChains.cpp
-@@ -4967,7 +4967,7 @@
- // macro for it. Also, select the default PTX version to be used. We use 4.2 for
- // compute capabilities older than 6.0 and 5.0 otherwise.
- #ifndef OPENMP_NVPTX_COMPUTE_CAPABILITY
--#define OPENMP_NVPTX_COMPUTE_CAPABILITY 53
-+#define OPENMP_NVPTX_COMPUTE_CAPABILITY 62
- #endif
- #if OPENMP_NVPTX_COMPUTE_CAPABILITY < 60