]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/clamav/clamav.mk
clamav: add patch to fix build failure caused by lack of libcurl
[coffee/buildroot.git] / package / clamav / clamav.mk
index 9a4063fd8232f95f9adf4bde1f87fa35be68a409..c0138a8944f3389e7a6aff75816428693b27dc91 100644 (file)
@@ -4,27 +4,37 @@
 #
 ################################################################################
 
-CLAMAV_VERSION = 0.98.5
-CLAMAV_SITE = http://sourceforge.net/projects/clamav/files/clamav/$(CLAMAV_VERSION)
-CLAMAV_LICENSE = GPLv2
+CLAMAV_VERSION = 0.100.0
+CLAMAV_SITE = https://www.clamav.net/downloads/production
+CLAMAV_LICENSE = GPL-2.0
 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
-       COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.regex COPYING.sha256 \
+       COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
        COPYING.unrar COPYING.zlib
-# clamav-0002-static-linking.patch touches configure.ac
+CLAMAV_DEPENDENCIES = \
+       host-pkgconf \
+       libtool \
+       openssl \
+       zlib \
+       $(TARGET_NLS_DEPENDENCIES)
+# 0003-m4-reorganization-libs-curl.m4-fix-curl-config-detec.patch
 CLAMAV_AUTORECONF = YES
-CLAMAV_DEPENDENCIES = openssl zlib $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
 # mmap cannot be detected when cross-compiling, needed for mempool support
 CLAMAV_CONF_ENV = \
-       ac_cv_c_mmap_private=yes
+       ac_cv_c_mmap_private=yes \
+       have_cv_ipv6=yes
 
+# UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
 CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \
+       --with-ltdl-include=$(STAGING_DIR)/usr/include \
+       --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
        --with-openssl=$(STAGING_DIR)/usr \
        --with-zlib=$(STAGING_DIR)/usr \
+       --disable-zlib-vcheck \
        --disable-rpath \
-       --disable-clamuko \
        --disable-clamav \
+       --disable-fanotify \
        --disable-milter \
        --disable-llvm \
        --disable-clamdtop \
@@ -40,6 +50,13 @@ else
 CLAMAV_CONF_OPTS += --disable-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_JSON_C),y)
+CLAMAV_CONF_OPTS += --with-libjson=$(STAGING_DIR)/usr
+CLAMAV_DEPENDENCIES += json-c
+else
+CLAMAV_CONF_OPTS += --without-libjson
+endif
+
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
 CLAMAV_DEPENDENCIES += libxml2
@@ -61,4 +78,11 @@ else
 CLAMAV_CONF_OPTS += --without-iconv
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE),y)
+CLAMAV_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
+CLAMAV_DEPENDENCIES += pcre
+else
+CLAMAV_CONF_OPTS += --without-pcre
+endif
+
 $(eval $(autotools-package))