]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/gpm/gpm.mk
gpm: fixes build error when makeinfo is not installed on host
[coffee/buildroot.git] / package / gpm / gpm.mk
index 6fd5a3fa2c788112120545f3945ae944fb063972..296966addc8561e2376b430341bfbdd354ade6be 100644 (file)
@@ -32,6 +32,15 @@ GPM_POST_PATCH_HOOKS += GPM_RUN_AUTOGEN
 
 GPM_DEPENDENCIES += host-automake host-autoconf host-libtool
 
+# gpm tries to build/install .info doc even if makeinfo isn't installed on the
+# host, so we have to disable global doc installation to prevent autobuild
+# errors.
+define GPM_DISABLE_DOC_INSTALL
+       $(SED) 's/SUBDIRS = src doc contrib/SUBDIRS = src contrib/' \
+               $(@D)/Makefile.in
+endef
+GPM_POST_PATCH_HOOKS += GPM_DISABLE_DOC_INSTALL
+
 ifeq ($(BR2_PACKAGE_GPM_INSTALL_TEST_TOOLS),)
 define GPM_REMOVE_TEST_TOOLS_FROM_TARGET
        for tools in mev hltest mouse-test display-buttons \