]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/ffmpeg/ffmpeg.mk
Merge branch 'next'
[coffee/buildroot.git] / package / ffmpeg / ffmpeg.mk
index 5a19617992972ab02aa2703cb0d0a5718418f5f9..a90d437e4fa1a74bd5cffe3e07ad34b660ae1741 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-FFMPEG_VERSION = 2.8.7
+FFMPEG_VERSION = 3.1.3
 FFMPEG_SOURCE = ffmpeg-$(FFMPEG_VERSION).tar.xz
 FFMPEG_SITE = http://ffmpeg.org/releases
 FFMPEG_INSTALL_STAGING = YES
@@ -40,7 +40,7 @@ FFMPEG_CONF_OPTS = \
        --enable-runtime-cpudetect \
        --disable-hardcoded-tables \
        --disable-memalign-hack \
-       --disable-mipsdspr1 \
+       --disable-mipsdsp \
        --disable-mipsdspr2 \
        --disable-msa \
        --enable-hwaccels \
@@ -48,7 +48,6 @@ FFMPEG_CONF_OPTS = \
        --disable-frei0r \
        --disable-libopencore-amrnb \
        --disable-libopencore-amrwb \
-       --disable-libopencv \
        --disable-libcdio \
        --disable-libdc1394 \
        --disable-libfaac \
@@ -57,7 +56,6 @@ FFMPEG_CONF_OPTS = \
        --disable-libnut \
        --disable-libopenjpeg \
        --disable-libschroedinger \
-       --disable-libvo-aacenc \
        --disable-libvo-amrwbenc \
        --disable-symver \
        --disable-doc
@@ -217,13 +215,6 @@ FFMPEG_CONF_OPTS += --disable-openssl
 endif
 endif
 
-ifeq ($(BR2_PACKAGE_LIBDCADEC),y)
-FFMPEG_CONF_OPTS += --enable-libdcadec
-FFMPEG_DEPENDENCIES += libdcadec
-else
-FFMPEG_CONF_OPTS += --disable-libdcadec
-endif
-
 ifeq ($(BR2_PACKAGE_FFMPEG_GPL)$(BR2_PACKAGE_LIBEBUR128),yy)
 FFMPEG_DEPENDENCIES += libebur128
 endif
@@ -257,6 +248,15 @@ else
 FFMPEG_CONF_OPTS += --disable-vdpau
 endif
 
+# To avoid a circular dependency only use opencv if opencv itself does
+# not depend on ffmpeg.
+ifeq ($(BR2_PACKAGE_OPENCV_LIB_IMGPROC)x$(BR2_PACKAGE_OPENCV_WITH_FFMPEG),yx)
+FFMPEG_CONF_OPTS += --enable-libopencv
+FFMPEG_DEPENDENCIES += opencv
+else
+FFMPEG_CONF_OPTS += --disable-libopencv
+endif
+
 ifeq ($(BR2_PACKAGE_OPUS),y)
 FFMPEG_CONF_OPTS += --enable-libopus
 FFMPEG_DEPENDENCIES += opus
@@ -447,14 +447,6 @@ FFMPEG_CONF_OPTS += --disable-mipsfpu
 else
 FFMPEG_CONF_OPTS += --enable-mipsfpu
 endif
-
-ifeq ($(BR2_mips_32r2),y)
-FFMPEG_CONF_OPTS += \
-       --enable-mips32r2
-else
-FFMPEG_CONF_OPTS += \
-       --disable-mips32r2
-endif
 endif # MIPS
 
 ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
@@ -469,12 +461,17 @@ else
 FFMPEG_CONF_OPTS += --disable-pic
 endif
 
-ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
+# Default to --cpu=generic for MIPS architecture, in order to avoid a
+# warning from ffmpeg's configure script.
+ifeq ($(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el),y)
+FFMPEG_CONF_OPTS += --cpu=generic
+else ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
 FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_CPU)
 else ifneq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),)
 FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_ARCH)
 endif
 
+
 FFMPEG_CONF_OPTS += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
 
 # Override FFMPEG_CONFIGURE_CMDS: FFmpeg does not support --target and others