]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/python-web2py/python-web2py.mk
package/python-web2py: remove admin panel
[coffee/buildroot.git] / package / python-web2py / python-web2py.mk
index 3f9d089bcd54dcd464683cfb9cf4331639cc6afe..887925b64ebbff4e0994155da18b4747437f7d38 100644 (file)
@@ -36,7 +36,11 @@ define PYTHON_WEB2PY_GENERATE_PASSWORD
                save_password($(BR2_PACKAGE_PYTHON_WEB2PY_PASSWORD),8000)'
 endef
 
+ifeq ($(BR2_PACKAGE_PYTHON_WEB2PY_INSTALL_ADMIN),y)
 PYTHON_WEB2PY_POST_BUILD_HOOKS += PYTHON_WEB2PY_GENERATE_PASSWORD
+else
+PYTHON_WEB2PY_EXCLUSIONS += applications/admin
+endif
 
 define PYTHON_WEB2PY_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/var/www/web2py