]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/samba4/samba4.mk
Merge branch 'next'
[coffee/buildroot.git] / package / samba4 / samba4.mk
index bb546f0837334fdbdcd9ad466aa0d8909155dbd7..e424861f678ee1a99c21b92bbbcede62f74574ea 100644 (file)
@@ -155,6 +155,9 @@ define SAMBA4_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/smb.service
        ln -sf ../../../../usr/lib/systemd/system/winbind.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/winbind.service
+       $(INSTALL) -D -m 644 $(@D)/packaging/systemd/samba.conf.tmp \
+               $(TARGET_DIR)/etc/tmpfiles.d/samba.conf
+       printf "d /var/log/samba  755 root root\n" >>$(TARGET_DIR)/etc/tmpfiles.d/samba.conf
 endef
 
 $(eval $(generic-package))