]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/clamav/clamav.mk
clamav: add patch to fix build failure caused by lack of libcurl
[coffee/buildroot.git] / package / clamav / clamav.mk
index 16178cd1f1a233a11b1346b230d6b29fbf9ec976..c0138a8944f3389e7a6aff75816428693b27dc91 100644 (file)
@@ -4,17 +4,20 @@
 #
 ################################################################################
 
-CLAMAV_VERSION = 0.99.1
-CLAMAV_SITE = http://sourceforge.net/projects/clamav/files/clamav/$(CLAMAV_VERSION)
-CLAMAV_LICENSE = GPLv2
+CLAMAV_VERSION = 0.100.0
+CLAMAV_SITE = https://www.clamav.net/downloads/production
+CLAMAV_LICENSE = GPL-2.0
 CLAMAV_LICENSE_FILES = COPYING COPYING.bzip2 COPYING.file COPYING.getopt \
        COPYING.LGPL COPYING.llvm COPYING.lzma COPYING.pcre COPYING.regex \
        COPYING.unrar COPYING.zlib
 CLAMAV_DEPENDENCIES = \
        host-pkgconf \
+       libtool \
        openssl \
        zlib \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+       $(TARGET_NLS_DEPENDENCIES)
+# 0003-m4-reorganization-libs-curl.m4-fix-curl-config-detec.patch
+CLAMAV_AUTORECONF = YES
 
 # mmap cannot be detected when cross-compiling, needed for mempool support
 CLAMAV_CONF_ENV = \
@@ -24,8 +27,11 @@ CLAMAV_CONF_ENV = \
 # UCLIBC_HAS_FTS is disabled, therefore disable fanotify (missing fts.h)
 CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \
+       --with-ltdl-include=$(STAGING_DIR)/usr/include \
+       --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
        --with-openssl=$(STAGING_DIR)/usr \
        --with-zlib=$(STAGING_DIR)/usr \
+       --disable-zlib-vcheck \
        --disable-rpath \
        --disable-clamav \
        --disable-fanotify \
@@ -44,6 +50,13 @@ else
 CLAMAV_CONF_OPTS += --disable-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_JSON_C),y)
+CLAMAV_CONF_OPTS += --with-libjson=$(STAGING_DIR)/usr
+CLAMAV_DEPENDENCIES += json-c
+else
+CLAMAV_CONF_OPTS += --without-libjson
+endif
+
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 CLAMAV_CONF_OPTS += --with-xml=$(STAGING_DIR)/usr
 CLAMAV_DEPENDENCIES += libxml2