]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/swig/swig.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / swig / swig.mk
index cdf9533f2acbd74243a63597fcbfce178d153ac8..157d3a39a69cf9d94d984a87b6a3e2d8bfa6c730 100644 (file)
@@ -18,19 +18,19 @@ SWIG_LICENSE_FILES = LICENSE LICENSE-GPL LICENSE-UNIVERSITIES
 # CMake looks first at swig3.0, then swig2.0 and then swig. However,
 # when doing the search, it will look into the PATH for swig2.0 first,
 # and then for swig.
-# While the PATH contains first our $(HOST_DIR)/usr/bin, it also contains
+# While the PATH contains first our $(HOST_DIR)/bin, it also contains
 # /usr/bin and other system directories. Therefore, if there is an
 # installed swig3.0 on the system, it will get the preference over the
-# swig installed in $(HOST_DIR)/usr/bin, which isn't nice. To prevent
+# swig installed in $(HOST_DIR)/bin, which isn't nice. To prevent
 # this from happening we create a symbolic link swig3.0 -> swig, so that
 # our swig always gets used.
 
 define HOST_SWIG_INSTALL_SYMLINK
-       ln -fs swig $(HOST_DIR)/usr/bin/swig$(SWIG_VERSION_MAJOR)
+       ln -fs swig $(HOST_DIR)/bin/swig$(SWIG_VERSION_MAJOR)
 endef
 
 HOST_SWIG_POST_INSTALL_HOOKS += HOST_SWIG_INSTALL_SYMLINK
 
 $(eval $(host-autotools-package))
 
-SWIG = $(HOST_DIR)/usr/bin/swig$(SWIG_VERSION_MAJOR)
+SWIG = $(HOST_DIR)/bin/swig$(SWIG_VERSION_MAJOR)