]> rtime.felk.cvut.cz Git - coffee/buildroot.git/blobdiff - package/qt/qt.mk
Globally replace $(HOST_DIR)/usr/bin with $(HOST_DIR)/bin
[coffee/buildroot.git] / package / qt / qt.mk
index e9af8f4be12da253333e35b8eb8d52ed2288339d..cb1f01e1f06db61e43fe4fe5dcd989bbaadab445 100644 (file)
@@ -461,7 +461,7 @@ endif
 # End of workaround.
 
 # Variable for other Qt applications to use
-QT_QMAKE = $(HOST_DIR)/usr/bin/qmake -spec qws/linux-$(QT_EMB_PLATFORM)-g++
+QT_QMAKE = $(HOST_DIR)/bin/qmake -spec qws/linux-$(QT_EMB_PLATFORM)-g++
 
 ################################################################################
 # QT_QMAKE_SET -- helper macro to set <variable> = <value> in
@@ -502,7 +502,7 @@ define QT_CONFIGURE_CMDS
        $(call QT_QMAKE_SET,QMAKE_CFLAGS,$(QT_CFLAGS),$(@D))
        $(call QT_QMAKE_SET,QMAKE_CXXFLAGS,$(QT_CXXFLAGS),$(@D))
        $(call QT_QMAKE_SET,QMAKE_LFLAGS,$(QT_LDFLAGS),$(@D))
-       $(call QT_QMAKE_SET,PKG_CONFIG,$(HOST_DIR)/usr/bin/pkg-config,$(@D))
+       $(call QT_QMAKE_SET,PKG_CONFIG,$(HOST_DIR)/bin/pkg-config,$(@D))
 # Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
 # instead of the host then. So set PKG_CONFIG* manually.
        (cd $(@D); \
@@ -590,7 +590,7 @@ ifeq ($(BR2_PACKAGE_QT_TEST),y)
 QT_INSTALL_LIBS += QtTest
 endif
 
-QT_CONF_FILE = $(HOST_DIR)/usr/bin/qt.conf
+QT_CONF_FILE = $(HOST_DIR)/bin/qt.conf
 
 # Since host programs and spec files have been moved to $(HOST_DIR),
 # we need to tell qmake the new location of the various elements,
@@ -602,7 +602,7 @@ define QT_INSTALL_QT_CONF
        echo "Headers=$(STAGING_DIR)/usr/include" >> $(QT_CONF_FILE)
        echo "Libraries=$(STAGING_DIR)/usr/lib"   >> $(QT_CONF_FILE)
        echo "Data=$(HOST_DIR)/usr"               >> $(QT_CONF_FILE)
-       echo "Binaries=$(HOST_DIR)/usr/bin"       >> $(QT_CONF_FILE)
+       echo "Binaries=$(HOST_DIR)/bin"       >> $(QT_CONF_FILE)
 endef
 
 # After running Qt normal installation process (which installs
@@ -614,12 +614,12 @@ endef
 # automatically.
 define QT_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
-       mkdir -p $(HOST_DIR)/usr/bin
-       mv $(addprefix $(STAGING_DIR)/usr/bin/,$(QT_HOST_PROGRAMS)) $(HOST_DIR)/usr/bin
+       mkdir -p $(HOST_DIR)/bin
+       mv $(addprefix $(STAGING_DIR)/usr/bin/,$(QT_HOST_PROGRAMS)) $(HOST_DIR)/bin
        ln -sf $(STAGING_DIR)/usr/mkspecs $(HOST_DIR)/usr/mkspecs
        $(QT_INSTALL_QT_CONF)
        for i in moc uic rcc lupdate lrelease ; do \
-               $(SED) "s,^$${i}_location=.*,$${i}_location=$(HOST_DIR)/usr/bin/$${i}," \
+               $(SED) "s,^$${i}_location=.*,$${i}_location=$(HOST_DIR)/bin/$${i}," \
                        $(STAGING_DIR)/usr/lib/pkgconfig/Qt*.pc ; \
        done
        $(SED) "s,$(STAGING_DIR)/,,g" $(STAGING_DIR)/usr/lib/pkgconfig/Qt*.pc